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Preface
Welcome to AndeSight™, the integrated software development environment for embedded SoC.

About this manual
AndeSight™ consists of IDE (Integrated Development Environment) and Toolchains providing the
complete and integrated environment for users to develop the software. Through working with
AndESLive™, virtual evaluation platform, users will be able to run the simulation of the
applications more easily and convenient.
This manual explains AndeSight™ in detail from the novice aspect and guides the users how to
start to use the tools by example projects.

Version of AndeSight
This manual covers the latest release features and functionalities of AndeSight/AndESLive
Developer Suite version 1.0.

Contact information
Please contact Andes Technology Corporation by email at andes-up-support@andestech.com or
on the Internet at www.andestech.com for support.

Copyright notice
© 2006 Andes Technology Corporation. All rights reserved.
AndeSight™ contains certain confidential information of Andes Technology Corporation. Use of
this copyright notice is precautionary and does not imply publication or disclosure. No part of this
publication may be reproduced, transmitted, transcribed, stored in a retrieval system, or
translated into any language in any form by any means without the written permission of Andes
Technology Corporation.

Copyright © 2006 Andes Technology Corporation

2

AndeSight™ User Manual v1.0

Chapter 1

Introduction and Overview

This chapter introduces the AndeSight™ and supporting facilities provided by Andes Technology
Corporation.
AndeSight™ Development Tool contains the following section:
1.1 AndeSight™ integration overview on page 4
1.2 IDE overview on page 4
1.3 Toolchains overview on page 14
1.4 AndESLive™ overview on page 15
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1.1 AndeSight Overview
AndeSight, a versatile development tool, consists of IDE (Integrated Development Environment)
and supporting Toolchains. Through perfectly connecting with AndESLive, we provide a complete
set of development tools for the process of writing code on one system, known as a host, and
running on another system, known as a target.
This chapter provides an overview of whole development concept (as shown in Figure 1-1), and
an introduction to basic AndeSight features and functionality.
The following diagram indicates the full view of AndeSight and AndESLive, and the relationship
between each part.

AndeSight IDE

Simulation

Toolchains,

Engine

compiler,
linker,

SoC Builder

ICE
Real Board

assembler
AndESLive

Figure 1-1: AndeSight

1.2 IDE Overview
AndeSight IDE is an Eclipse-based development suite that provides an efficient way to develop
embedded applications of the target system.
AndeSight IDE is based on Eclipse 3.1. This section provides a brief introduction to the
Workbench features which are common to all Eclipse-based systems. For a more detailed
introduction, please refer to the online Help (by selecting Help > Help Contents, expand the
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Workbench User Guide entry) or go to www.eclipse.org/documentation.
AndeSight IDE is described with several terms: Windows, Views, Editor, Perspective, and
Plug-ins. The following sections outline these terms and explain how to use these features.

1.2.1 Windows
The term Window is used only for the overall outer frame shown in Figure1-2. Use
Window > New Window to create a new same outer frame.

Figure1-2: Application Development Perspective
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1.2.2 Views
The term View refers to the individual panes within a window. As Figure1-2 shows, the Project
Explorer view on the left side of the screen, the Outline view on the top-right, and the stacked
view on the bottom-right with the title Tasks, such as console, problems and properties etc.
Many views include a menu that is accessed by clicking the down arrow to the right of the title bar.
This menu typically contains items that apply to the entire contents of the view rather than a
selected item within the view.
To open a view and add it to the existing perspective (see 1.2.3 Perspectives), select Window >
Show View. Select the desired view from the list, or select Other… to display expandable lists
with more choices. The view is added at its default location in the window, and you can move it if
desired. The following section lists some frequently used views.
▪ Project Explore View (as shown in Figure1-2)
The C/C++ Project Explore view displays the relevant elements to C and C++ project files in
a tree structure. For detailed information, please refer to the help content by clicking Help >
Help Contents > Eclipse Platform Guide > C/C++ Development User Guide > Concepts
> Navigation aids > Project File views.
▪ Source Code View
The Source Code view provides specialized features for editing files. Please refer to 1.2.4
Editors.
▪ Properties and Console Stack (as shown in Figure1-2)
The Properties view displays property names and values for a selected item. For detailed
information, please refer to the help content by clicking Help > Help Contents > Eclipse
Platform Guide > C/C++ Development User Guide > Reference > C/C++ Views and
Editors > Properties View.
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▪ Outline View (as shown in Figure1-2)
The Outline view displays an outline of a structured C/C++ file that is currently open in the
editor area, by listing the structural elements. For detailed information, please refer to the
help content by clicking Help > Help Contents > Eclipse Platform Guide > C/C++
Development User Guide > Concepts > Navigation aids > Outline View.
▪ Debug View

▪
The Debug view let you control program execution, such as Run, Pause, Terminate, Step
into, and Step over etc. For detailed information, please refer to the help content by clicking
Help > Help Contents > Eclipse Platform Guide > C/C++ Development User Guide >
Reference > C/C++ Views and Editors > Debug View > Debug View.
▪ Registers View

▪
The Registers view of the Debug perspective lists information about the registers in a
selected stack frame. Values that have changed are highlighted in the Registers view when
your program stops. For detailed information, please refer to the help content by clicking
Help > Help Contents > Eclipse Platform Guide > C/C++ Development User Guide >
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Reference > C/C++ Views and Editors > Debug View > Registers View.
▪ Disassembly View

▪
Disassembly view lets you examine your program as it steps into disassembled code. This is
useful when the instruction pointer enters a function for which it does not have the source.
For detailed information, please refer to the help content by clicking Help > Help Contents >
Eclipse Platform Guide > C/C++ Development User Guide > Tasks > Running and
debugging projects > Debugging > Stepping into assembler functions.
▪ Memory View

▪
Memory view lets you examine the content of your program’s memory space. Memory view
contains two panes - Memory Monitors and Memory Renderings pane. Memory Monitors
pane displays the list of memory monitors added currently. Memory Renderings pane is
controlled by the selection in the Memory Monitors pane and consists of the tabs that display
renderings. For detailed information, please refer to the help content by clicking Help > Help
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Contents > Eclipse Platform Guide > C/C++ Development User Guide > Reference >
C/C++ Views and Editors > Debug View > Memory View.
▪ Variables View

▪
Variables view displays variable types and let user change or disable variable values. For
detailed information, please refer to the help content by clicking Help > Help Contents >
Eclipse Platform Guide > C/C++ Development User Guide > Tasks > Running and
debugging projects > Debugging > Working with variables.

1.2.3 Perspectives
A Perspective is the initial set and layout of views in the Window. Each perspective
provides a set of functionality aimed at accomplishing a specific type of task or works, for
example creating projects, browsing files, and editing and building source code. A single
window can maintain several perspectives, but show only one perspective at a time.
To open new perspectives and switch between them, use the icons in the shortcut bar
along the top right edge of the window. For example, if you want to switch the Coder
perspective to Debug perspective, click Window > Open Perspective > Debug or Select
Debug on the perspective shortcut bar.
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Then the Debug perspective appears, containing the Debug, Breakpoints, Local Variables, and
Console views and so forth, which are useful when running and debugging a program. These
views replace the Outline view of the C/C++ coder perspective.
The Andes IDE contributes the following perspectives to the workbench:

 Andes Coder perspective
This perspective is tuned for working with C/C++ projects. By default it consists of an editor area
and the following views:
▪ Project explore (the file navigator for C/C++ resources)
▪ Navigator (the file navigator for all Eclipse resources)
▪ Console
▪ Properties
▪ Problems
▪ Outline

 Debug perspective
This perspective is tuned for debugging your C/C++ program. By default it includes a Debug area
and the following views:
▪ Variables
▪ Breakpoints
▪ Expressions
▪ Registers
▪ Memory
▪ Outline
▪ Console
▪ Tasks

 VEP Config (AndESLive) perspective
This perspective is tuned for working with AndESLive projects. (See section 1.4 for description of
AndESLive). By default it consists of a VEP builder area and the following views:
▪ VEP Project explore
▪ Properties
▪ Outline
▪ Memory Mapping
▪ IRQ Map
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▪ VEP Manager

 Profiler perspective
This perspective is tuned for profiling your C/C++ program. By default it includes the following
views:
▪ Debug
▪ Project explore
▪ Console
▪ Tasks
▪ Variables
▪ Breakpoints
▪ C/C++ editor

 Other Perspectives
In addition to the perspectives named above, Andes also has perspectives that are tuned to other
types of development. To open other perspectives, click the icon

in the shortcut bar, and then

select Other….

The followings are other perspectives we provide:
▪ CVS Repository Exploring
▪ Resource
▪ Team Synchronizing
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You can also create your own perspectives to suit your development needs. Follow the steps
below to create a customized perspective:
1. Arrange the views in the window as desired by opening any required views and moving them
to an appropriate location.
2. Select Window > Save Perspective As, enter a name for your custom perspective.
3. Click OK.
Note: 1. The customized perspective is saved in the workspace.
2. Switch back to the C/C++ coder perspective by clicking its icon on the top right side and resetting it
with Window > Reset Perspective.
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1.2.4 Editors
Editor is a special type of view used to edit files. You can associate different Editors with different
types of files such as C, C++, XML, Assembler, and Make files. The associated Editor is invoked
in the perspective's Editor area while you open a file.
Any number of Editors can be open at once, but only one can be active at a time. By default,
Editors are stacked in the Editor area, but you can tile them in order to view source files
simultaneously. Tabs in the Editor area indicate the names of files that are currently open for
editing. An asterisk (*) indicates that an Editor contains unsaved changes.
C/C++ editor is provided with complete functionalities helping you edit your source code, such as
Content Assist, which is a set of tools built to help reduce the number of keystrokes you must type.
Content Assist consists of several components that forecast what a developer will type, based on
the current context, scope, and prefix. It provides code completion and code templates features
which triggered by typing Ctrl + Space. For more detailed information, please refer to the help
content by clicking Help > Help Contents > Eclipse Platform Guide > C/C++ Development
User Guide > Concepts > Code aids > Content Assistant.

1.2.5 Plug-ins
The Eclipse platform is structured as a core runtime engine and a set of additional features that
are installed as platform Plug-ins. When you start up the workbench, you are not starting up a
single program. You are activating a platform runtime which can dynamically discover registered
plug-ins and start them as needed. Through adding the plug-ins, AndeSight contributes complete
functionality to the platform letting users develop their program more convenient and easily.
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1.3 Toolchains
GNU based toolchains:
▪ Compiler
▪ Assembler
▪ Linker
▪ GDB Debugger
▪ GDB agent
Toolchains utilities will be invoked via IDE interface to build your target software from the project.
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1.4 AndESLive Overview
AndESLive consisting of SoC simulation engine and SoC Builder provides the models of Andes
CPU and peripheral devices.
With the AndESLive, Virtual Evaluation Platform, you can go from simulation to prototyping for
SoC with minimal or no time spent characterizing physical evaluation boards. It provides the
flexibility for you to evaluate SoC configuration and performance to meet the requirements of your
whole system.
Here is the pre-configured SoC AG101 that we provide as an example in AndESLive.

AG101

Bus Controller
(Arbiter, Decoder)

N12

MAC
10/100

SDRAM
Controller

LCD Controller

USB 2.0
Device

DMA Controller

Static Memory
Controller

AHB to APB
Bridge

I2C

PWM

Power Manager

IrDA

ST
UART

GPIO

BT
UART

INTC

FF
UART

WDT

Timer

SSP

CF

RTC

I2S/
AC97

SD/
MMC

Figure 1-3: Block Diagram of AG101 VEP
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The following lists all components of AG101:
▪ CPU / MMU / CACHE
▪ Bus controller
▪ MAC 10/100
▪ USB 2.0
▪ LCD controller
▪ SDRAM controller
▪ DMA controller
▪ Static memory controller
▪ AHB to APB bridge
▪ PWM
▪ I2C
▪ GPIO
▪ INTC
▪ WDT
▪ Timer
▪ RTC
▪ Power manager
▪ IrDA
▪ ST UART
▪ BT UART
▪ FF UART
▪ CF
▪ SSP / I2S / AC97
▪ SD / MMC
Note: For detailed information, please refer to AndESLive reference.
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Chapter 2

Installation Guide

This chapter provides a quick overview of how to set up AndeSight. It contains the following
sections:
2.1 Contents of installation package on page 18
2.2 Optimum system requirements on page 18
2.3 Installation procedure on page 18
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2.1 Contents of Installation package
The whole installation package contains:
▪ AndeSight
Ð IDE
Ð Toolchains
▪ AndESLive
Ð Virtual Evaluation Platform
Ð Components models
▪ Documentations
▪ Cygwin
▪ IBM JVM (Java Virtual Machine)

2.2 Optimum system requirements
To install and run AndeSight, you should have the following:
▪ Windows XP operating system
▪ 1 Gigabytes of RAM for minimum requirement
▪ 1 Gigabytes of free disk space for installation

2.3 Installation procedure
The InstallShield wizard will guide you into the set-up process. The following steps will be brought
out.
Step 1 Double click AndeSight_Install.exe file
Welcome to the installation of AndeSight

Step 2 Click Next
Step 3 Enter the User and Company names, and then click Next
Step 4 Choose Complete to install all the features of AndeSight or Custom to choose the
features, and then click Next
Step 5 Click Change to change the destination directory or use the default directory, and
then click Next
Step 6 Choose what features you want to install (For Complete installation, skip this step)
Step 7 Click Install to begin the installation
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Step 8 Installation complete and click Finish to exit the wizard
Installation completes.
Note: Default option is to install the whole package.
1. Complete installation will install the whole package including Cygwin, IBM JVM, and AndeSight.
2. Custom installation will let user choose what component they want to install.
3. Cygwin is a Linux-like environment for Windows. Installation of Cygwin is the prerequisite of
running AndeSight.
4. Linux Platform version will be released in Q1, 2007
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Chapter 3

Getting Started

The following provides a tutorial that walks you through all the major features of AndeSight IDE:
creating projects, building and debugging code, connecting to VEP, and running your program.
3.1 Create a new project on page 21
explains the Project System, including creating new projects, importing and exporting
existing projects, and creating user applications
3.2 Editing on page 24
describes the Editor, Static Analysis, and Build System features of Workbench
3.3 Build on page 25
3.4 Start GDBAgent and VEP on page 26
3.5 Target Management on page 27
provides details about using the Target Manager, including how to configure a target
server, and how to create and manage your target connections
3.6 Debugging on page 28
explains Debugger functionality, including launch configurations, attaching the
debugger to processes, working with breakpoints, displaying processes in the Debug
and Disassembly views, and examining registers and memory
3.7 Profiling on page 30
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3.1 Create a new project
This section describes in great detail the process of creating, compiling, and running a simple
“Hello, World” program. It is best if you actually run AndeSight while reading this section and
perform the steps as they are described.
With the installation procedure in Chapter 2, you can easily start AndeSight by the following
steps:
1

Invoke AndeSight from Desktop’s shortcut “AndeSight IDE” or from Windows Start Menu
Programs > Andestech > AndeSight > AndeSight. Workspace launcher dialog will ask
you to define a workspace as shown in Figure 3-1. You can click the Browse … button or
type directly in the text field to define the preferred workspace directory. Press OK button
after done.
Workspace is where a project is saved. Users can create multiple workspaces required by
different projects or teams. Furthermore, users can keep the whole workspace and use in
next release of AndeSight.

Figure 3-1: Define the preferred workspace directory

2

The present screen should be “Welcome to AndeSight 1.0” page as shown in Figure 3-2.
This welcome page provides three links for your quick guide into AndeSight IDE, which
are Overview, Getting Started, and Examples. (This page could also be invoked after you
enter the workbench by clicking Help > Welcome in IDE). For now, click the curved arrow
on the top of the right hand side to enter the IDE Workbench as shown in Figure 3-3.
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Figure 3-2: Welcome page

Figure 3-3: AndeSight Workbench
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3

The Welcome page only presents at the first time starting AndeSight. Afterward, you will
always get the views that you previous work on. To create a new project, you can easily
click File > New > Project… and the Project wizard will guide you through the whole
process.
▪ Select File > New > Project …, a new project wizard will popup to guide you to create
a project.
▪ Expand Andes Project by clicking the “+” icon, and then select either C or C++ project
based on your application program. For this tutorial, please select C project and press
Next.
▪ Please input Hello as the project name in the next dialog and then click Finish.
▪ The Hello project will be created and shown in the Project Explore as the Figure 3-4.

Figure 3-4: Create a demo Project
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3.2 Editing
The next step for the project is to create a C source code file and edit it, but in this tutorial,
AndeSight provides a pre-prepared example for you to add in the new project.
▪ Select the Hello project and click the File > Import…, then the Import dialog will be
popup.
▪ Select the File System and click Next (or double click the File System).
▪ Click Browse and navigate the directory structure to <AndeSight-installed-path>\hello,
and then click OK.
▪ In the left window of the Import dialog, click the hello folder. The files inside the hello folder
will be shown in the right window.
▪ Check the checkbox of the hello.c, and then click Finish.
The Project Explore now shows that hello.c has been added to the project. Source file in the
Project Explore can be edited by double clicking on its icon.
Note: 1. There are many convenient editing tools provided, such as Search, Refactoring, Syntax
coloring, and Auto-completion.
2. There is no executable image existing for the project yet.
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3.3 Build
Select the project Hello you just created, right click to invoke the Build Project command. Builder
will call Andes’ backend toolchains to create the make file and compile, link and at last generate
the executable file. The compiler and linker have several options which could be configured by
right-clicking the project selecting Properties.

Figure 3-5: Build Properties
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3.4 Start GDBAgent and VEP
Before running your program/software, you need to set up the backend simulation environment.
For your convenience, Andes provides you GDBAgent to complete this task.
1

from Windows Start Menu Programs > Andestech > AndeSight > Cygwin, GDBAgent is
started in Cygwin prompt by
%> GDBAgent –v none
GDBAgent is to coordinate and handle all the detail communications between/among
front-end IDE and back-end VEP and ICE. The GDBAgent utilizes the socket IO to
communicate between AndeSight components, so that the front-end IDE could be run on
such as local desktop PC, and VEP could be run on Linux server; in this way users would
get benefit in both convenience and efficiency.

Note: You can also start the GDBAgent in a shell on Linux server by this same command as above.

2

Start Virtual Evaluation Platform (VEP) by selecting Advance > Start VEP from menu bar
or clicking Start VEP icon

from toolbar. The following VEP Manager shows the control

GUI of VEP.

Figure 3-6: VEP Manager

3

Drag the general.vep file from Project Explore and drop to the space next to Select VEP
Config.

4

Press Start Simulator to start simulator.

5

AndeSight IDE will pass the vep file to VEP through GDBAgent. The SoC configured in
the vep file will be run as the simulation target.

Note: 1. Cygwin is a Linux-like environment for Windows
2. The total duration of VEP startup and connection will be around 15 seconds.
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3.5 Target management
To run and debug the program, you need to specify the target before executing the program by
the following steps:
1

Select Run > Debug… from menu bar, a Debug dialog is popup to let you set the VEP
configuration, including the simulator of AndeScore and models of peripheral IPs. Select
Cross Platform Application and press New. A demo configuration will be created under
Cross Platform Application.

Figure 3-7: Target Configuration to run the executable

2

Click the third tab Target on the right pane and click Auto Select button for selecting a
VEP. You can select evaluation board VEP-1, VEP-2, or VEP SID-Simulator-1 from the
Select Target dialog. Select SID-Simulator-1 for VEP and click OK to finish.
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Figure 3-8: Select target

3

The Debug configuration dialog will be appearing and then click Debug button to run the
selected project on the target.

4

AndeSight will automatically switch to Debug Perspective which is shown as Figure 3-9.
Debug will be discussed in the section 3.6.

3.6 Debugging
AndeSight provides integrated and advantageous views for debugging in the Debug perspective.
A software debugging could be a series of complicated tasks such as error detections, source of
bugs locating, and validation of the program etc. Figure 3-9 shows the views of Debug
perspective provided by AndeSight.
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Figure 3-9: Debug perspective

1

The program will stop at the main() entry and a pointer locates at the line after main().
There are two views presenting different information of the source code. The execution
could step in different formats, either in higher level C source code or lower level
assembler, depending on your debugging needs. In the Debug view, icons at the tool bar
are Run

, Pause

, Step into

, Step over

, and Terminate

etc. The root of

the content is the application, and the Cross Platform Debugger below the root indicates
the target you specify in section 3.5 Target management.
2

Select main() at hello.c in the Debug view as shown in Figure 3-9, and press Step over.
The source code view will show a green indicator for current position of execution. In the
Disassembly view, there will be a corresponding cursor pointing to the highlighted line of
assembly code.

3

Memory view provides a very convenient way to inspect the data in memory after loading
or storing. The memory cells changing between the steps such as stepping or suspending
will be shown with arrow,

4

The result will be shown in the Console view.
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Note: 1. All the debug-related views do not refresh while you run your executable. The refreshment
occurs when the execution stops.
2. For more information, please refer to the online Help > Eclipse Platform Guide > C/C++
Development User Guide > Tasks > Running and debugging projects > Debugging

3.7 Profiling
After programs have been debugged, the next task of programmers will be to tune the software
and hardware in order to get the better performance. Andes provides Profiling function letting
users observe and examine their programs and hardware more easily.
The following describes the profiling steps.
1

To start the profiling, please switch the perspective from Debugger to Profiler first.

2

As you can see, project explore will be on your left hand side. Right click the project that
was being debugged, and then select Profile As > Profile….

3

Profiling dialog will show and inherit the settings you just set in the debugging dialog.

4

Click Profile.

5

Trigger the Enable Source Profiling icon

6

Click Resume to run the program till finished, and then click

to start the profiling.
icon again to terminate

profiling.
7

Now refresh the project explore, you will find prof.out generated in the profile folder.
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8

Double click prof.out or click

to show profiling results. In order to present detailed and

clear profiling, we provide three views, which are timeline, call, and flat view. The
followings will demonstrate and explain these views and their features.
Note: You can also profile between two breakpoints through triggering the profiling at the first
breakpoint and terminating at another breakpoint.

Flat View
The flat view shows the total amount of time your program spent executing each function. You
can sort the data by different column.

Here is what the fields in each line mean:
▪ Time %
This is the percentage of the total execution time your program spent in this function.
These should all add up to 100%.
▪ Cumulative Instruction and Cycle count
This is the cumulative total number of instructions and cycles the simulator spent
executing the functions, plus the time spent in all the functions above this one in this table.
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▪ Self Instruction and Cycle count
This is the number of instruction and cycle accounted for by this function alone. The flat
profile listing is sorted first by this number.
▪ Calls
This is the total number of times the function was called. If the function was never called,
or the number of times it was called cannot be determined (probably because the function
was not compiled with profiling enabled), the calls field is blank.
▪ Self Instruction/Cycle per call
This represents the average number of instructions and cycle spent in this function per
call, if this function is profiled. Otherwise, this field is blank for this function.
▪ Total Call Instruction/Cycle count
This represents the average number of instructions and cycles spent in this function and
its descendants per call, if this function is profiled. Otherwise, this field is blank for this
function. This is the only field in the flat profile that uses call graph analysis.
▪ Name
This is the name of the function. The flat profile is sorted by this field alphabetically after
the self seconds and calls fields are sorted.
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Call view
The call view shows how much time was spent in each function and its children. From this
information, you can find functions that, while they themselves may not have used much
time, called other functions that did use unusual amounts of time.

Parent lists the callers and Child lists the callee of each entry.

Copyright © 2006 Andes Technology Corporation

33

AndeSight™ User Manual v1.0

Timeline view
The timeline view allows you to track function calls as they occur over a period of time. This is
useful for viewing function call sequence. Even though the program is recursive or has
repeated loops, the function calls will be listed separately.
Once finding any query and needing modifications of the source, you can right click the
function, and then Go to Source will popup. Through this, you can easily find and switch to
the source position for review.
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Chapter 4

Advanced Usages with project tutorial

This chapter discusses the advanced usages of Andes by introducing the two examples. Users
will acquire further understanding and advanced usages of AndeSight through the tutorial.
4.1 Audio – MP3 Decoder on page 36
4.2 JPEG on page 42

Copyright © 2006 Andes Technology Corporation

35

AndeSight™ User Manual v1.0

4.1 Audio - MP3 Decoder
As an embedded product, MP3 decoder is a primitive request for Andes SoC solution. This
section will guide you into the advance usage of AndeSight using MP3 Decoder project provided
by Andes. The VEP configure including processor, memory module, bus, and an audio peripheral
will be demonstrated in this project.
You will be experiencing the debugging and finally get the audio output. Through these
procedures, you will get further understanding of the integration of Andes IDE, VEP, and
Toolchains.

4.1.1 Project Import
▪ Start AndeSight from Windows Start menu
▪ Import MP3 project by clicking the menu bar File > import…
▪ Select Existing Projects into Workspace from the next appearance shown as below, and
click Next.

Figure 4-1: Import Dialog
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▪ Check the Select archive file: and click the Browse… button to select the
<AndeSight-installed-path>/demo/MP3_demo.zip

Figure 4-2: Import Projects Dialog

▪ Press Finish to complete the project import.
Note: To import the project, you can either right click to select Import… or choose File > Import…
from the menu bar.
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4.1.2 Source Code Editing
▪ The MP3 project will be shown in the Project Explore. You can select the MP3 node and
right-click the mouse choosing Build Project. Then clicking on the plus sign “+” to expand
the project, you will see Binaries, Includes, and Debug folders and mp3play.c and
builder-gen2.vep files.
▪ Double click the mp3play.c, the C/C++ editor and the Outline view of the source code will
be invoked.

Figure 4-3: Source Code Editor and Outline View
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4.1.3 VEP Builder
▪ Double click the audio.vep. VEP builder will be invoked presenting the configuration of
the file and letting you edit or modify.

Figure 4-4: VEP Builder

▪ The VEP builder represents the hardware configuration in the high level perspective. It’s
of functional level connecting IPs like cpu, memory, bus, and an audio device (audio
should be connected to APB instead of AHB? Thus APB and AHB-APB bridge should be
there). The CPU is simulated by the ISS and the compiled programs will be loaded into
Memory. The MP3 will be decoded into PCM format and saved into memory, then sent to
the audio device played.
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4.1.4 Start GDBAgent and VEP
▪ Start VEP as described in the section 3.4
▪ Drag the audio.vep file from Project Explore and drop to the space next to Select VEP
Config.
▪ Press the button of Start Simulator. Then the simulator and correspond frontend will be
invoked as shown in Figure 4-5.

Figure 4-5: MP3 Decoder Front-end

▪ Set and Select the target as described in the section 3.5

4.1.5 Debugging
▪ Select the project MP3 right-clicking the mouse, and from the menu invoked, select
Debug As > Debug…
▪ Select the Cross Platform Applications, and then press the New button.
▪ AndeSight will automatically setup most execution options for the target and scan the
available VEPs in network and list them for you to select. Click the Auto Select button as
shown in Figure 4-6.
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Figure 4-6: Debug Configuration Setup

▪ Select the target listed and press OK in the next dialog.
▪ Click Debug button to start debugging. While program is being debugged, the perspective
will be switched to Debug perspective and debug process will be shown in Console view.
▪ After debugging, the result will be shown from the front-end: Audio simulator.
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4.2 JPEG
JPEG decoder is another common program in SoC. This section will guide you into the JPEG
project demonstrating decoding eight jpeg images in a set and displaying the result on the
emulated LCD panel in the end. The application will use LCD controller and two memory sections
to show how to debug between C source code and memory.
Follow the steps below to accomplish the project:

4.2.1 Import the project and start VEP
1.

Follow the same steps as the section 3.2 to import the prepared project JPEG.zip from
<AndeSight-install-path>/demo/

2.

Build the project.

3.

Start the GDBAgent and SID simulator as described in the section 3.4, but drag the
different configuration file from Project Explore: jpeg.vep to the space next to Select
VEP Config. Then you will find that VEP front-end - LCD simulator is invoked.

4.

Select the target as described the section 3.5.

5.

Start debugging and the Debug perspective will be open.

4.2.2 Debugging
1.

The top left view shows the process, thread, and core stack of current debugging
application. And, on the right hand side, there are 4 major views stacked together –
Variables, Breakpoints, Modules, and Registers.

2.

The debugger will initially stop at the first executable code in main function.

3.

Variables of current scope will be automatically queried from VEP and listed in the
Variables view.

4.

To see all registers of AndeScore, you could click the plus sign “+” to expand Main
processor in the Registers view.

5.

Press Ctrl-F (or click Edit > find/replace from the menu bar) or scroll downward for 10
~ 20 lines to find djpeg_main. Right-click on the left side bar (or click Run > Toggle
Line Breakpoint on the menu bar) to add a breakpoint on this line. You could see all
the breakpoints set in the Breakpoints view.
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6.

Press Resume

button. The execution will continue and stop at the calling of

djpeg_main. Click Step into

, then the execution will go into djpeg_main().

7.

Check the Variables view, and you will find the variable set is different now.

8.

In the Registers view, there are several registers changed to red, which means the
registers are loaded by different values between breaks.

9.

Try to add one more breakpoint on line 744 as the following highlighted:
while (cinfo.output_scanline < cinfo.output_height)
{
num_scanlines = jpeg_read_scanlines(&cinfo, dest_mgr->buffer,
dest_mgr->buffer_height);
(*dest_mgr->put_pixel_rows) (&cinfo, dest_mgr, num_scanlines);
}

10. Resume again, you will see the picture is decoded line by line on the virtual LCD
panel.

11. Disable all breakpoints by un-checking the checkbox, and press Resume button. The
application will run with full speed and you will soon see the picture is displayed on the
virtual LCD panel.
Note:
1. Above steps show the general breakpoint usage. You could track the current scan line by
adding a variable in the code, such as:
int current_line = 0;
while (cinfo.output_scanline < cinfo.output_height)
{
num_scanlines = jpeg_read_scanlines(&cinfo, dest_mgr->buffer,
dest_mgr->buffer_height);
(*dest_mgr->put_pixel_rows) (&cinfo, dest_mgr, num_scanlines);
current_line ++;
}

2. Right-click the breakpoint in the Breakpoints view and select Properties…. Then input
current_line == 40 in the Condition:
3. Compile and run again. The program will be suspended on the breakpoint only when
current_line == 40. This could help debugging more efficient.
4. Eight JPEG pictures are decoded and presented now on the virtual LCD panel.
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